Androguard软件安装方法

Androguard是目前最好的开源Android分析工具之一,项目地址是:

http://code.google.com/p/androguard/

Androguard依赖于很多第三方库,各个库又有不同的环境要求。多次尝试后,得到一个能顺利安装所有功能的流程。平台是Linux x86 + Python 2.6。其他系统、体系、Python版本都没有成功。

具体步骤如下:

(下载freemind思维导图文件: androguard_installation.zip)

Linux x86

  • Ubuntu 11.04 i386

VCS

  • sudo apt-get install subversion
  • sudo apt-get install mercurial
  • sudo apt-get install git

Python 2.6 (full)

  • sudo apt-get install python2.6 python2.6-dev
  • sudo rm /usr/bin/python
  • sudo ln -s /usr/bin/python2.6 /usr/bin/python

~ psyco

  • svn co http://codespeak.net/svn/psyco/dist/ psyco-dist
  • cd psyco-dist
  • sudo python setup.py install

~ networkx

  • hg clone http://networkx.lanl.gov/hg/networkx networkx-1.5
  • cd networkx-1.5
  • sudo python setup.py install

~ IPython

  • wget http://ipython.scipy.org/dist/0.10.2/ipython-0.10.2.tar.gz
  • tar xzvf ipython-0.10.2.tar.gz
  • cd ipython-0.10.2
  • sudo python setup.py install

~ python-ptrace

  • hg clone https://bitbucket.org/haypo/python-ptrace
  • cd python-ptrace
  • sudo python setup.py install

~ pyparsing

  • svn co https://pyparsing.svn.sourceforge.net/svnroot/pyparsing pyparsing
  • cd pyparsing/src
  • sudo python setup.py install

~ Graphviz

  • sudo apt-get install graphviz

~ pydot

  • svn checkout http://pydot.googlecode.com/svn/trunk/ pydot-read-only
  • cd pydot-read-only
  • sudo python setup.py install

~ Chilkat Zip

  • wget http://www.chilkatsoft.com/download/chilkat-9.2.0-Python-2.6-i686-linux.tar.gz
  • sudo tar xzvf chilkat-9.2.0-Python-2.6-i686-linux.tar.gz -C /

~ setuptools

  • wget http://pypi.python.org/packages/2.6/s/setuptools/setuptools-0.6c11-py2.6.egg
  • chmod a+x setuptools-0.6c11-py2.6.egg
  • sudo ./setuptools-0.6c11-py2.6.egg

~ python-magic

  • git clone git://github.com/ahupp/python-magic.git
  • cd python-magic
  • sudo python setup.py install

~ pyfuzzy

~ Androguard

  • hg clone https://androguard.googlecode.com/hg/ androguard
  • DONE!

Androguard软件安装方法》上有9条评论

  1. PeterLin

    there is a problem.when i just do it as the essay says,but when i compile the lib under the ~/psyco-dist/networkx-1.5/ipython-0.10.2/python-ptrace/pyparsing/src/pydot-read-only/python-magic/pyfuzzy-0.1.0/androguard directory, there comes a “In file included from dvm.cc:21:0:
    dvm.h:23:20: erroe: Python.h:file or directory not exist”…i need your help

    回复
  2. goodhacker

    我在使用androguard时遇到以下问题是怎么回事啊?
    >>> import androguard
    >>> _a = androguard.AndroguardS( ‘./examples/java/Hello.class’ )
    Traceback (most recent call last):
    File “”, line 1, in
    AttributeError: ‘module’ object has no attribute ‘AndroguardS’
    另外,按照你的安装步骤完成之后是不是还需要make一下啊?但是我在make的时候也出现错误,郁闷

    回复
    1. Claud 文章作者

      hi,这篇文章介绍的步骤,因为androguard后续更新较大,已经不能使用了。建议参看官方的wiki页面。

      回复
      1. goodhacker

        谢谢。但是官方的wiki页面说的也不够详细,安装不起来啊。还是希望你能够尽量帮帮忙。

        回复
  3. goodhacker

    博主啊博主,你犯了一个致命的错误,害得我安装不成功啊。ubuntu版本必须是10.04而非11.04

    回复
    1. Claud 文章作者

      hi, 11.04的python默认是2.7了。我发这篇文章的时候,在11.04下,把默认python改为2.6,是可以安装的。另外,现在安装方法已经不同了,建议看下官方说明。

      回复
  4. zlk

    请教楼主,你在安装完各种第三方库后,输入make命令之后的编译过程中有没有出现如下错误:
    In file included from /usr/include/c++/4.4/ext/hash_map:60,
    from ../formula/formula.h:35,
    from elsign.h:28,
    from elsign.cc:21:
    /usr/include/c++/4.4/backward/backward_warning.h:28: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
    本人所用平台:ubuntu 11.04 gcc-4.4 python 2.7 这些有无问题,你用的gcc是哪个版本的?本人十分着急,请赐教。

    回复
    1. Claud 文章作者

      hi,
      这篇文章介绍的安装方法已经不适用于新的版本,请按照项目wiki页面的installation来装~
      我也没有遇到过你说的问题。

      回复

发表评论

电子邮件地址不会被公开。 必填项已用*标注